Out of memory trying to allocate a rendering resource

D5 Render Version:
Graphics Card: NVIDIA GeForce RTX 3080 Laptop GPU
Driver Version:
Issue Description:

I added a lot of d5 assets to my project yesterday (landscaping, grass, interior parallax, entourage, etc.) and the program worked fine while it was open. Today the file gets to 9% before coming up with the message “Out of memory trying to allocate a rendering resource” and then closes when I click OK.

I updated my graphics card driver, lowered the resolution of my monitor significantly, ran the program as administrator, and restarted the computer multiple times, yet it still won’t open.

Is there a way to lower the resolution d5 uses on materials, assets, etc. without opening the program? Or is there some other troubleshoot to open the program?


How about the usage of the Dedicated GPU memory and memory when running this scene file?

Here are the stats you asked for. The memory gets up to 30 GB in use before the program crashes. Thanks so much!

Hello @idelaiglesia

The message “Out of video memory” may be due to insufficient Video memory/Memory. You have 31.7 GB of RAM, but it’s currently at 94%; D5 relies heavily on video memory and only reads ‘Dedicated GPU memory’, and generally D5 will crash if the video memory is over 80% occupied (yours is 93%). Is this a large scene you are running? Does this popup appear when running other scenes, such as a D5 demo scene? I suggest you try to increase the memory stick on your PC/optimize the graphics memory&memory usage.

**D5 Render Version:
**Graphics Card: RTX 3050 Laptop GPU (updated to latest version)
**Issue Description: I am trying to connect my Rhino file (that is quite big - 2.34GB), but it fails

I tried two ways to open my file. When I connect it through Rhino 7, in Rhino it says that it’s connected, but D5 crashes and closes. When I try to open the file directly from D5 it loads until 99% and gives me the “out of video memory…” message.
I also reinstalled the latest version of the Plugin for Rhino, it didn’t change anything.
I would appreciate it if anyone knows how to solve this issue

Hello! Could you please send your log file to us? You can refer to this post to learn how to collect logs. D5 Support Tool - Get Help / Tech Support - D5 RENDER FORUM
You can share a link of your log here or send it to our email (please attach the link of this port to your mail).