D5 2.5.1 Version stuck on Initializing

Hi all,

since I installed the latest 2.5.1 Version, D5 does not initialize. It is stuck on the launch screen “Initializing”…

Opening through Rhino (Launcher Plug-in) is responsive, but also does not launch D5 (blocked at 99%).

Other than that, no other pop-up or further info comes up, the software is just stuck there.

Specs:
OS Windows 11 Pro
PROC Intel i7 8650U CPU 4 Cores // 16 GB RAM
GC Nvidia GTX 1060 6GB

PS: Issue is the same when trying the older 2.4 version, which worked perfectly before…does not launch.

Any help would be much appreciated…would like to Upgrade to PRO but am reluctant until this issue is solved.

Thank you!
NM

Hi, sorry for the inconvenience caused by the problem. Can you also show us the info of your GPU driver and system version? some users solved that by updating one of them.

You can also refer to this blog for possible solutions: Crashes/Restarts/Fails to Load - Get Help / AnswerHub - D5 RENDER FORUM

If the problem persists, please run a clean installation of the GPU driver, and also run this dll repair tool: Got notification of “Launch failure might be caused by system DLLs missing, try to repair it automatically?” or stop loading at 0% - Get Help / AnswerHub - D5 RENDER FORUM 2

If this still happens, please send the scenes and log files to us for troubleshooting
support@d5techs.com

How to collect log files: D5 Support Tool

Same problem for me D5 stuck on initialization. Tried every solution I could find on this forum. Nvidia 4070 ti driver is updated, windows 11 system is updated, every driver updated and working.

Only D5 doesn’t work. D5 version 2.5.2.0332.
And it is not the Norton Antivirus (also disabled it) that consider D5 a safe program.

This is the screen shoot: