Connection problem with ArchiCAD. (D5: Inadequate Permissions & AC23: Connect Error )

Hi everyone,
I’m having problems connecting ArchiCAD (23) and D5 Render. On the D5 Render side, I get an error message like this:
When I want to open a file I saved with version 2.2:

Inadequate Permissions.
No permission to save this project, you can save as a new one.

Also on ArchiCAD:
Connect Error
Please retry after exit rendering mode or finish the rendering within D5 Render.

But actually I’m not in “rendering mode” on the D5 side.

NOTE: I have not encountered this type of problem with other files saved with previous versions of D5. Only one file gives such error message.

D5 Render Version: 2.2.0.0314 Pro
Graphics Card: NVIDIA GeForce RTX 3090
Driver Version: 512.15
**Issue Description:
SS 2022-04-21 230943
**
Screenshots/Videos Description:
Steps to Reproduce (optional):

Hello, only one file gives this error message? First, I think it can be related to permission settings, does the file need admin permission to edit? Please check this topic:
I use revit sync and my files keep getting lost! - Get Help - D5 RENDER FORUM

Second, this issue may also be caused due to unsupported file name/ file path, does the file path/name have special characters or Turkish?Please try changing it to English file path then open again.

Any updates would be appreciated.

Hi @Oliver.J,

Thank you for your interest. I tested many way and I guess found a solution:
The new version of D5 Render could not save the file in this folder because the main folder name where my project is saved contains Turkish characters. I cleaned the TR characters in the path, my problem was solved.

D5 Render should use universal character code, such as UTF8. No other software I used -such as Twinmotion, Libre Office, Inkscape, GIMP, PhotoShop etc.- gives such errors. Regional Settings wrks correctly. Except ArchiCAD, except Artlantis… and now D5 with its new version are also on this black list.

I can give another example for that “regional problem”:
I’m windows user and I setted my input method to my default regional settings of my country.

But some text fields in D5 Render UI do not allow me to enter numbers according to my country’s settings. For example, decimal separators are made with “commas” in my country. But some text fields in D5 Render accept numbers I entered with periods, not commas, as correct. This is not acceptable. So it wants me to enter “0,4” instead of “0.4”.

Before enter the text field: Separator is comma.
Comma

After enter the text field: Now separator is point.
Point

I think some things are going wrong in the background. Am I wrong?

D5, should found a way that regional input problem.