Runtime error (at 68:328):

Hello, I got this message when installing the sync plugin for Blender. I have Blender 3.6.5 installed on my device. What seems to be the problem? I tried reinstalling both apps, still the same. I tried with Blender 3.4 and 3.5 installed, yet the problem still occurs. Please I need help.

Hi @miftahulhuda0281,

to let it work, you need to download and install both D5 Render and the D5 Converter, have you installed D5 Render as well?
D5 Render | Real-Time Ray Tracing 3D Rendering Software
If the problem persists, please let me know.

Yes, I have D5 installed on my device.

The sync plugin for other software like SketchUp and Archicad works just fine, it only happened with Blender sync :frowning:

Hi, sorry to hear that.
Please send your log to us (, and please describe the problem better attach a link of this post). You can refer to this post to learn how to collect logs. D5 Support Tool

It is probably the plugin installation problem. Please try to uninstall the plugin and reinstall it first, if it still doesn’t work, please contact us again.
This shows how to uninstall:

The converter is not even installed on my device yet, therefore I don’t have the option to uninstall it. I don’t have that “uninstall D5 converter for Blender” app on my start menu or in the Blender add-ons list.

You mean you can’t install converter? check if you can see it occurs in your Blender-preferences-add-ons. If yes, please delete it and try to install again.If no, just reinstall again. Here’s a link.
Blender to D5 Render Real-Time Rendering Workflow

Yes, I cannot install the converter. After selecting the setup language, that runtime error occurs.

Sorry for your problem.
Can you post a video recording when you installing converter? We could be able to track your problem better.

Sure, sent through e-mail to D5 team. Thank you.

Got it. Thank you so much.

1 Like

Hey, is there a way I can download the older version of the converter to see if that may work?

did you found the solution because now i am having the same issue

hi leah_Li i am having the same issue as miftahulhuda i reinstalled both blender and d5 and yet the problem persist ( run time error ). i am using blender 4.0 and latest build of d5
previously i was using d5latest build and blender 3.6 .i did use 3.6 again to check if its working but unfortunately its completely broken

Hello, are you currently using the latest blender sync plugin? I suggest you can try to update to the latest version of the plugin.

hello thankyou for the reply , yes i am using the latest version of the plugin and the latest version of d5 . i tried installing every other d5 pluging and they just work fine no error whatso ever even tho i dont even own those software in the first place .
issue occurs when i try to install the blender sync . it wont show the installation tab instead shows the run time error , btw i did sent a mail to the d5tech team explaining the whole issue but didnt recieved a reply there

Sorry for your issue. We are on holiday now, so we are currently only providing technical support in the forums and will hold off on responding to emails.
Have you tried updating the windows version? Also, do you have any popups reporting errors? If so, are they the exact same popups as previously mentioned in this thread?

hi , happy holidays btw yes my windows is up-to-date and no i dont get any other error as soon as i click on the exe file it gives me a promt of installation i click ok and then like 2-3 sec later it just gives me that error , is there any way that u can provide me an older built like just the previous build . i searched your forum and i found a really old built and it only works with blender 3.4 but i need to upgrade blender because i do have some blender addon that i really need to work but it dosent support 3.4 version of blender