Plugin Archicad 25 error


I have downloaded the latest plugin from the website, where it says now it covers up to Archicad 25 as well, but I cannot install it. It says the installation is complete but actually it doesn’t install anything, it shows 0.00kb.

The previous version was installed successfully when I had AC 23.

How can I resolve it, is there a way to uninstall the previous plugin and install the new one? I have attached some photos of the process.
Thank you.



It seems that the D5 Converter can’t find the installation path in your register table.

Please check if your AC is installed normally, or reinstall the AC with administrator admission.


Still the same thing. I have uninstalled Archicad and D5 and reinstall both of them again with administrator permission.

Hello, where did you download the plugin? From this site: Download | D5 Render
Or from D5 Render Welcome page? could you give me a screenshot of the version number?

Hi Oliver,

Yes, I have downloaded it from the Download section on the website. I have installed the Archicad 25 Solo Licence on Win10 Pro x64.

The name of the file is D5_Converter_ARCHICAD_usa_0.3.4.exe and in the screenshot it says the version is 27th May 2020.

Thank you.
Screenshot 2022-01-06 084359

Hello Chris, please download from here again:
Download | D5 Render


The current version is 0.4.0, which supports AC25.
You are using 0.3.4, which does not support AC25…

Hi Oliver,

I have downloaded the 0.4.0 version from the download page and still have the same issue. Even tried to download it through the D5 app and still the same.
I have also tried to install it with admin permission and without but still the same result.
Screenshot 2022-01-06 102307
Screenshot 2022-01-06 102504
Screenshot 2022-01-06 102515
Screenshot 2022-01-06 102606

Oh, sorry, does your AC25 has right registry files? I mean, can you find AC25 in your Windows start list?

HI Oliver,

I assume it has, I have reinstalled AC25 with admin permission with the typical settings, in the default directory in Program Files. I haven’t changed anything.
And it appears also in the start menu.
Screenshot 2022-01-06 110411

Hello Chris, you are using AC25 Solo, not AC25, I think that is the reason why the plugin cannot recognize it. We will try to add it to our support list as soon as possible.

Hello! I have normal AC25 and I have the same issue. Nothing shows up on the install path

Do you have any troubleshoot for this?

1 Like

Hi, follow this solution. Oliver and the team were very helpful.

Hi Chris,

Thanks for the fast reply! I can’t seem to follow your link though…
Tried pasting without the u=chris and other variations but nothing worked

It states that the thread is private

Sorry about that.
@Oliver.J can post the updated plug-in, maybe it helps you as well.


I have found some links on other posts to download alternative AC plugins but none worked… the files were d5c_archicad_install.7z . Is this what you are talking about?

Yes, that’s the one. I believe mine installs the latest version 4.3.0 converter. When you open AC after the plugin installation it should prompt which version is installed.

Please try this new version of plugin then install again:
d5c_archicad_install.7z (4.0 MB)

If the problem remains, it may be not able to recognize the Archicad on your pc, did you reinstall the system or the AC25 lost the registry key (is it in the Start menu of Win10)?

1 Like

The problem remains… I had a version of AC24 installed that I uninstalled thinking that it could have been confusing the installment. But it still persists.
AC25 show up fine in the start menu.

Could it be the antivirus? I have no way of shutting it down because I have restricted acess to admin.

Any other sugestions?

Hello, I think uninstalling AC24 can be the reason because it will delete the registries. Could you install the AC25 again to cover the current one then try again? In this way, it will write registries again. Also, it would be good if you can run the plugin installer as admin.
If the problem remains, please let me know, we will help you solve the problem.