Physx - cpu

D5 Render Version


after the last 2 updates I have been getting issues with slow navigation on models, even the small demo ones and long render times that didn´t happen before.
I have tried switching the physx from cpu to gpu at the nvidia control panel and the issue remains. The gpu is working properly since I checked on the control panel device manager. Nvidia DSSL is turned ON in D5.

What can I do to correct this situation.
Best regards, Miguel.


Hi BAAM, sorry to hear that you ran into this problem. From your description, it seems that the RTX GPU is not used to run D5 Render. Please change the Physx to GPU, and also adjust the settings here to make sure D5 Render uses 3060 ti.

What’s more, you can also upgrade the video driver (the one you use is 496), and restore its settings to default.

If the problem remains, feel free to contact us. Also, are you using a laptop? Whether it is linked with a second monitor?

Hello Oliver,
thanks for the reply.
I updated the nvidia drivers to the latest. I reseted the d5 configurations on the nvidia control panel and I set the physx to gpu but on the 3d settings tab if I choose show physx visual indicator, once I go back to d5 it shows that phisx is still runing on cpu.

In conclusion the d5 is runing on cpu phisx and for some reason it wont change. I can barely navigate on de church model wich is small, with high quality, and the render times are slow.
I´m using a pc with single monitor.

In this page, whether D5 Render uses RTX 3060?

Also, is your monitor connected to the RTX 3060, or the mother board?

If the problem remains, please send the two folders to my email

  1. A folder called logs, in the installation directory of D5 2.2
  2. A folder called Saved, in C:/Users/your account/AppData/local/d5_immerse