FBX mapping

Hello D5 render team.
I would like to try D5 and pair it with Bricscad in my workflow.
I tried exporting simple model from BricsCAD to fbx and opened it in D5. It can recognise objects and materials applied (even if they are only white). I can change them, but mapping is totally wrong and cannot scale texture UVs correctly, because the mapping is either too big or too small, or too stretched. Slider in UV editing is not enough in this case. On top of that, every object has different UV stretching, so same materials look different on both (see two columns, with same material).
I know it is bad UV mapping, but in Bricscad the textures are applied nicely with some default cube mapping. Is this possible to fix in D5? Some default cube mapping when applied material?

1 Like

Anyone to help with this please?

Hi,
Post the model so we can have a look.

Hey, you can find it here:

Thanks

1 Like

Hi Gravis,
I’m not familiar with your Cad program, but I think you’re not exporting the model correctly.
I noticed your walls are in segments.
Where is the folder of the textures?
You need to export all the models and textures in one folder.
Also, change your mapping to UV not cubic and maybe it will work.

Definately your export not correct, I tried to convert to obj and the FBX convertor failed.

OK, I will try to play with export settings more.
But anyway, it would be very nice to have possibility to apply in D5 with some default cubic mapping instead of UVs…
Thanks

I dont think they have cubic mapping, only UV

So I was not able to export correctly .fbx from Bricscad. I checked in Blender and UVs are missing in UV space, even if UV exists.
But I tried .dae from Bricscad, then resave as .fbx in Blender. This worked well.

Maybe this will help someone from other CAD apps which has problems with UVs.

Hi, I know that’s its an old post, but maybe try to use triplanar UV in d5 render…maybe it might help

1 Like