D5 file corrupted after regular save

D5 Render Version: 1.9.1.0296 (Pro)
Graphics Card: RTX 3070
Driver Version: 471.68 (Studio driver)
Issue Description:
Hello. I have been working today on a project and imported a Sketchup file to D5 with the plugin. After working on the D5 file I saved it like always and turned off D5 (saved it again when prompted on exit).

An hour later, I want to open the same D5 file and the file is corrupted (see screenshot). When I open it there are no models, no scenes. I tried to open Sketchup and to run it from there with the plugin, but when I do that D5 asks me to start from a blank file.

I can locate the D5 file where I saved it on my SSD with a total size of 1.67 GB (see the second screenshot) but when I open it from there it’s again empty.

I am running D5 in admin mode all the time.

This is very frustrating because it happened to me already for the 3rd time and I am doubting a bit the reliability of the tool.

Is there any way to recover this file again? What can I do in the future to prevent it?

Screenshots/Videos Description:

Steps to Reproduce (optional):

Hello FlatBlack722, sorry for the inconvenience caused by this issue, have you changed the file path, or is the file path very long? This behavior is very abnormal as you mentioned it is the 3rd time. Could you please compress the folder then send it to ziyin.zhu@d5techs.com? We will look into it asap.

Best regards,
Oliver

First, we can try to recover the file if the 1.save file has a backup normally.
Second, we want to collect the logs to narrow down the issue cause, to make sure this problem will not happen again.
two log folders:

  1. A folder called logs, in the installation directory of D5 2.0
  2. A folder called Saved, in C:/Users/your account/AppData/local/d5_immerse

Hi @Oliver.J Thanks for the reply.

No the file path is not that long I assume. It goes like this: F:/Projects/Client_name/D5/Kitchen-living space

Could perhaps underscores in the pathway like “Client_name” cause the problem? I saw in a couple of other bug reports that it was suggested not to use those special characters for the D5 filename. Not sure if that applies also to the pathway?

I am uploading now the files that you asked for and I will send them on the email you shared. Is it okay if I send the log files to the email as well or do you want them here?

Thanks!

Yes, it would be better if you could send us logs to the email too. No problem!

@Oliver.J

I just sent everything to the email. Curious to know what caused the problem. Thanks for the help so far!

Hi FlatBlack722, very sorry to tell you that we have no way to recover this file, both the 1.save file and its temp backups are corrupt, we tried some ways to recover, but they do not work, opening the file just displays wrong code like NULNULNUL.

It is a known issue related with the UE engine, we changed our saving algorithm in 1.9.1 version to avoid this kind of problem. Unfortunately, the 1.save file is more complicated to write and save so we have no way to change it as well. For now, we are trying to overcome this problem on the algorithm, also develop an auto-save feature.

To prevent this issue from happening again, we kindly suggest you use space to replace _or- in the file name, or just remove those special characters. And you could backup your files manually when an important work is done.

This problem is related with incompatibility between UE4 and some settings(like language) in Win10, and we are developing to overcome it. Sorry again for this issue! We think this problem has little chance to appear in the next versions.

Regards,
Oliver

Hi @Oliver.J . Thanks for the elaboration and for the recommendation. I really hope this gets fixed as this is quite frustrating since D5 is not stable enough to be used as a go-to tool for interior design rendering. At least not for me from what I see.

Please prioritize stability over features for future releases.

2 Likes

Yes, it is on the highest priority, I think 2.0 should not have this kind of problem.

1 Like