Can't download materials

This has been my issue since 16 hours. I was able to download materials before but not now. This is after upgrading to the newer version. I even reverted back to the previous. it still doesn’t work. I have a good connection too. I used Unreal engine before but D5 gets the job done more easily. Would really appreciate some help.

Hi there,

Most of the material textures in Asset library are 4k resolution, which take a bit long time to download.

Please check out your network connection, disable the softwares like antivirus or VPN/proxy and try again.

If it still failed, please record a video about your operation and send me the 2 folders named Logs from your computer to :

  • Win C: “%local appdata%\d5_immerse\Saved\Logs”

  • Installation Directory of D5 Render: “D5 Render\logs”

Yes. The issue is solved. It was the windows defender making issues. Resetting it’s registry solved the issue. Thanks for the concern. Good support is a good software. Waiting eagerly for 1. 8 version. Peace.

Hello, I’m student from Kazakhstan and I have the same problem and I didnt understand how to solve it. Can you tell how did you do that.Thank you in advance

This is also my problem now.,.,can you please help…