Camera Path

**D5 Render Version: 2.3.2.0929
**Graphics Card: 3090ti
**Driver Version: not related
**Issue Description:

The automatic interpolation between keyframes of a video often leads to the camera diving below ground level, crashing into object, etc. Since I can’t control or fix the camera path manually, the video function is completely unusable for me.

I do understand a) how the smoothing is meant to work and that it certainly may look good in other cases and b) that theoretically I could add many more keyframes to fix the issue. However, the latter would lead to video definitions with way too many frames, jerky transitions, lots of extra maintenance effort, etc. etc.

A much simpler solution could be to offer one more “easing” option by which the algorithm would use the exact same path that is also applied when clicking inside the Scene List to switch between saved scenes. In this case, the camera moves my on-screen preview in a straight path, adjusting angle and zoom simultaneously. As a video, this path would look less like a smooth drone flight and more like a slideshow of still frames with nice animated transition between camera positions, but that’s exactly what I would need in most cases.

Hi! @mike
The camera doesn’t move smoothly currently and we are working on this issue.
But we have not encountered the case you mentioned where the camera dives below ground level or crashes into an object. Could you please record a video for this case? And the screenshot of key frame settings is also needed.

Sure! I’ve used your own example scene with a bit different viewing angles in the four scenes:

In the first part of the video I simply click through the scenes and the animated transitions are looking really good (or at least usable as a starting point for fine tuning).

After that, I put the same scenes (unchanged) as keyframes into a video and the camera immediately starts behaving very differently. The interpolation between frames seems to have some kind of “inertia” or “smoothing” built into the algorithm, which results in totally unusable video.

Please note that I do understand, of course, that by manually putting a lot more keyframes, I could potentially avoid this, but this would a) be lots of extra effort, b) potentially result in fast, jerky movements as those extra keyframes would be very close to each other on the timeline and c) would totally clutter my scene list with unnecessary entries…

My suggestion would therefore be to introduce an option that lets users choose between the “smoothed” camera path (today’s video default) and a more “linear” path that resembles what is happening when clicking between different scenes in the scene list.

1 Like

Sorry, didn’t record the part of the screen that was outside the preview window, but I guess it’s self explanatory… :slight_smile:

Sorry for the late reply. We did not reproduce this issue. Could you please keep the keyframe settings as shown in the screenshot below and then save the project and send it to me? My email address is rubyliu1107@gmail.com. Then I will check your keyframe settings.

Sorry to repeat but this is exactly my case as I wrote here. Not using camera path. Just keys.

It goes to the ground. Could be unit related coming from max?
Would be very nice to wrote the solution when you solve the issue so we don t need to be asking.
Thank you.

I’ve gone back to doing screen recordings of the transitions that are displayed when clicking in the scene list. Of course those are not rendered properly, just preview quality, but the path the camera is taking from one scene to the next gives me a perfect, linear interpolation between each pair of scenes, no matter where the camera is positioned. No overshooting, no funny dampening effects, just the quickest transition possible with smooth acceleration and deceleration. Exactly what I would love the animation algorithm to do as well…

Hello, yeah, we use some algorithm to make the movement smoother. It is not suggested to have more than one keyframes that have same camera positions.

Hi Oliver, I don’t have the same camera positions in any two scenes. What I’m observing as that your smoothing sometimes “overshoots“ quite a bit. If a keyframe is close to the ground, for example, the resulting curve may dip below ground, making the entire animation useless.

If, however, I am switching between the same two keyframes in the scene list, the resulting animation displayed in the viewport is much more useful. It is still smooth, but more linear.

All I’m asking is to replicate exactly what I am seeing in the viewport (a linear but smooth transition between two scenes) as a full definition rendered video.

I’ve spoken to other architects who were experiencing similar difficulties, it seems to be a common issue.

Hi Mike, ok, I think I understand the problem you encountered. We will see whether we can improve this.
Besides, the workaround you use is correct. For now, you can use set only two keyframes for a clip, dividing the video into several clips, at least the camera movement is more linear and will not exceed its position.