Unable to change location of "Asset Storage" in Preferences

Like the title suggests, I am unable to change my “Asset Storage” location. My team has a server that we store all of our projects/assets on, so we’d like to be able to create a centralized D5 Workspace on that server.

We’ve successfully been able to change the asset storage location for one PC; however, our other PC has been unable to change this. Is this a current limitation to the software in that there can only be one workspace per PC? Are we unable to share the same D5 Workspace?

Hello, I think there should be no this kind of limitation, could you please let me know how it did not let your other PC " be unable to change this"?

Hey Oliver,

I’ll include a screen snip below of the setting I am talking about. The issue is that when I try to update the location, nothing fills the “New Location” box and the confirm button always stays in that greyed out state.

The other PC updated the location on first try and we were able to click the confirm button. Not sure what could be causing the issue. I have already reinstalled a fresh version of D5 Render on the problematic PC, but that didn’t seem to fix the problem.

Hello Brendan, I think you may need to click this button to select a new location first, then the Confirm button will be clickable.

Oliver,

I tried the solution, but still no luck. I was able to record my screen this time. Hopefully this clears up the issue more.

I’ve uploaded the screen recording to Youtube

Thanks,
Brendan

Hey Oliver,

After some more trouble shooting on my end, I found a solution. It seems that the issue was caused by us using the same D5 Render Pro account on both PCs. When attempting to set a new “Asset Storage Location” using our second Pro license, we were successful.

Before, we were using the same account on both PCs and just signing out when moving between the two. Everything is working smoothly now that we have two separate licenses pointing to the same folder location.

Hopefully other people having a similar issue finds their answer here.

Thanks,
Brendan

Hello Brendan, sry for the late reply, we did a test and found it may not work as you described, because we do not set limitation on the file store location according to D5 accounts.
Since you mentioned you store the files in a server, I think you may enter a Relative address like this:
\10.xx.x.xxx\folder\files\xxx
which is not supported.

You should map your network drive to your local computer, then select the path like this in D5:
Z:\xxx\xx
Then it should work, no matter whether you have Pro accounts.
For reference, Map a network drive in Windows (microsoft.com)

Thanks,
Oliver

hey oliver,

we’ve got the same problem. we’re unable to change the location to a network-path.
d5 doesn’t show mapped network-drives but on the other hand i’m able to choose
a relative address, which i can’t confirm at the end.

is there a limitation for free acounts, maybe?

thanks,
patrick

Hi patrick,

Thanks for posting!

No, we do not set any limitation for that feature for free account, please do not worry.
I think it is still related to the network path.
As you mentioned, when you choose a relative address, the Confirm button will be greyed out.
But if you map the network drive correctly, D5 should recognize and be able to use it, please check this:

Or the network drive you use is a 3rd-party service? Please check the permission settings as well.
Any update would be welcome~

Br,
Oliver

thank you oliver for your reply,
so in the meanwhile we subscripted to the pro-service but the problem is still the same.
the network drives are mapped with the windows on board service (no 3rd-party tools).
perhaps is there an issue with windows 11?

i got it!
here’s the solution for other user:
add a new registry-key (d-word 32-bit) under “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System” - named “EnableLinkedConnections” with value 1.

if it’s still not working install the “SMB 1.0/CIFS file sharing support” in the windows features.
and don’t forget to restart your computer after each configuration!

1 Like

Hi,
Thanks very much for the solution. We will add it to our knowledge base to help more people, and hope you do not mind that.

Cheers,
oliver