Inaccurate light in animation

Hi, I have a problem with the animation. If I set the setting sun to complete darkness, there is still some light in the scene after the render. In the picture on the left is a screen from a rendered video and on the right is a screen from the preview in D5.

edit: D5 2.7., driver


are you using Geo and Sky or HDRI? Is the still frame image output all black the same as the preview?

I use Geo and Sky. But with HDRI it’s exactly the same problem and it only affects animations. The still frame image output is all black the same as the preview

Can you send this scene file to for testing? Please attach a link to this post in the email, so I can quickly find you. Thanks!

Hello @jakubkomarek3d

I tested your scene file.If you set the current environment to all black, the exported still frame image will be based on the current preview. Whereas the environment setting of the output video clip will be based on when it was saved, unless you click the update button. The output video will be consistent with the thumbnails here. Not sure if this is the case for you?

Hi, Leah,
I don’t understand. How do I set the video clip to be completely dark when the lights are turned off. Can you please post a simple scene with the settings?

Hi @jakubkomarek3d,

First, go into video mode, create a new blank clip, after turning the lights of the current scene to complete black, and then click ‘‘Create Shot’’. Not sure if you are in a similar situation, you can also send me a video to clarify.
Here’s a recording for reference: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Hi, Leah,

I uploaded a video, please check it out. Am I doing something wrong? In the D5 preview you can see the bad light around the window ( 00:51 in the video). After rendering the video, you can see a big difference in the first frame, it is brighter overall. In the last frame you can still see the light, where is it coming from?
After turning off all the lights, you can’t create darkness in the video!


It feels like it has something to do with the exposure value when outputting the video, before you create a shot you need to turn off auto exposure and set the exposure value to 0, otherwise the exposure value will still be in effect in the output result. This is supposed to result in an all-black effect. Btw, at this time we do not recommend adding keyframe animations to HDRI, which can cause the screen to flicker. You can try to make several animations of different HDRIs and then connect them together by editing and adding transitions to the shots.

I’m sending another video. The exposure value is at zero. There is still light in the render video.

I did some more testing. I closed the window completely and there is still light in the video. You can also notice how slowly the dimming occurs in the scene


I reported this to the team and we tested further. It is truly impossible to have both bright and dark environment light in the same clip at the moment. Light is fading out slowly by default. The only way to achieve total darkness is to keep the environment completely dark from start to finish in a separate clip. Thanks for clarification and understanding.
We do not recommend doing a sky or environment light gradient effect. If you need it, you can currently export multiple clips and stitch them together by use of some other editing software.

thank you for explaining. I wanted to know if this is a feature of the D5 or a bug on my side.
I’ll adapt my workflow to that.


thanks for pointing out. I suppose it’s a know issue/limit of D5, not a bug on your side. :saluting_face: