Errors in new converter Tool (

When exporting from Sketchup, some the materials don’t get correctly updated.
There is also a problem when saving because of that. An error appears, stating that the project cannot be saved, because it’s loading materials (see print screen). This never happened before with the old converter tool (0.6.9.xxxx). Please fix it as soon as possible. Thanks!!

Summary of this topic:
Question 1: after the synchronization, some materials lost
— you are suggested to open .skp file directly in D5 Render. And please download the latest D5 version, which should sole this question, If not, we need SketchUp model+D5 scene file for test.
Question 2: crash
— it is due to the plugin version update. please use this one: D5_Converter_SketchUp_test_0.7.2.0001.exe.7z and we will bring a fix next week.

Hi, this is because the scene is still loading materials from SketchUp. Please check the private message I sent you, we have a solution to this problem.

Kindly send me also this private massage fo i have also this problem. thank you

Please help me i have the same problem thanks

Hello, the official version of D5 2.3 has been released. Please open your D5 Render to upgrade it to D5 2.3, after that, the problem should be solved. It it persists, please let me know, thanks!

Dear i have already v2.3. standalone file in d5 opens with full materials but when sync with scketchup its removing some materials. my converter also is updated to v0.7.0.0011

i feel all started when i upgraded to v0.7.0.0011

Hi tttoros, sorry for that, we will release a fix soon. As a current workaround, you can open the skp file in D5 directly, not using live sync.

So grateful . Thank you so much

1 Like

Hello, for urgent use, you can try this new version:
D5_Render_installer- - Google Drive

Is the live sync issue also being solved with this version? Thanks

Hi, it should be, but we may need your feedbacks. If you can send us a sample skp and d5 file for testing, it will help us a lot. My email is

I can send you the files later today, no problem. I couldn’t reproduce the live link issue with this version, which is good. I will be testing later again with a heavy model.

What I noticed in this version is that the rendering times are double as long as the previous!!
For a 4k Rendering I had an average of 3.5 to 4 minutes. Today for the same scene 8 minutes! Why??

I can confirm that the live link issue is still not fixed. D5 Program ( does still crash when SketchUp is open. Especially on high poly models. Please fix it asap as it is a real pain. Thanks

Edit: the Problem seems to be the loading of textures, not Sketchup anymore! When the model has big sized textures (10-20mb) and mostly PNG, selecting a material, which has this texture applied to it leads to a crash. Especially if trying different textures for a material and hitting the Ctrl-Z combination a few times to go back to the previous material/texture leads to a crash!
RAM usage goes to 99% and after a few seconds the System freezes and it has to be restarted manually. If D5 is force closed over task manager before it freezes then PC doesn’t crash. I had several crashes of D5 in the last 24 hrs until I figured this out. Never had this problem with v2.2

Hi artedesigner, sorry for the late reply. We identified the issue cause is the update of SU plugin. For models imported through that version of SU plugin, they will consume more RAM than normal.
Therefore, it is suggested to directly open skp files in D5, or revert back to previous versions of D5 Converter for SketchUp.

We will bring a fix as soon as possible, thanks.

Does the new converter tool update fix the above mentioned issue?

Hello, yes, you can download and try this one, or wait for our update next week.
D5_Converter_SketchUp_test_0.7.2.0001.exe.7z (2.0 MB)

I can confirm, that with the new converter tool the material issue is gone in my scene. Thank you.

1 Like

Hi Oliver,

I have the same issue. I am using Converter when I save / save as to a file or new one. it comes up “the project is loading, please save it later” After waiting for a long time. D5 crash. no project has been save. Try so many times even reinstall D5 converter. still the same

Hello,does this problem happen to all D5 scene files sync-ed from SU, or a specific one? What are your video driver version and D5 Render version?