D5 Sync to Blender 4.0

does not work.
When does come the new release for sync?
Thank you


Hi @Flamingo,

D5 Render is currently compatible up to Blender 3.6. It is possible that Blender 4.0 will be supported in the future, but there is no exact time yet.
Thanks for your interest to D5.

1 Like

Thank you.
So FBX, including materials, would be a solution.
Does there anything happen for clean FBX?

I need Help.
My Blender freeze on my office PC after execute the “export or sync” button on D5 Sync Blender Add-On. I checked with my system administrator and they are asking if there are any special Blender exceptions for the firewall?

I use Blender 4.0.2


what’s the version of D5 Sync for Blender are you currently using? Please take a screenshot for me.


As soon as Sync is clicked, does Blender lose its response? Do specific scenes or all scenes have this issue? Can the model be successfully synced to D5?

Thanks Leah_Li for your help and reply.

I am using the latest version of D5 Sync for Blender and Blender version 4.0.2

Yes, when I try to click on “Export to .D5A” or “Sync”, Blender freezes completely and D5 doesn’t open either.

I had first installed D5 Render as Current User (AppData/Roaming) and then later installed it for all users (Admin) in the C:/ProgramData. But without success!

All scenes have this problem, and it doesn’t matter how big the file is. As a test I only tried to export the Blender Standard Cube.

As I said, I have this problem only on my office PC and I am trying to solve this problem with the help of the system administrator. But so far there is no solution.
They have said that they have already made the SSL exception on the firewall and are asking for further port releases for Blender or D5 and whether there are further exceptions to be made.

To clarify, I ran Blender and D5 via CMD Shell to see what errors occur. (See screenshot 1)

I hope you can interpret this and help me further.

Thank you very much!

As a comparison, here is the 2nd screenshot, which shows the successful export on my Home PC.

Sorry for your issue. You can try uninstalling the plugin and reinstalling it through the windows program panel. If this does not help, please contact me promptly.


Thanks Luna Lang for your help. I will give it a new try and will reinstall it. What do you exactly mean through “windows program panel”? I always installed via .exe

Hello LunaLang,

I have reinstalled and have the same problem. I have started Blender via command shell, and the first thing that puzzles me is always the following error message at the end.
“Get Update Error”

After activating the add-on, this error message always appears after restarting Blender.

Here is the entire output

C:\Program Files\Blender Foundation\Blender 4.0>blender.exe
Read prefs: “C:\Users\username\AppData\Roaming\Blender Foundation\Blender\4.0\config\userpref.blend”
[D5] Initialize Addon…
[D5] Registering Addon…
[D5][REGISTER] Registering Material Serialization…
GA init
GA launch
Get update error

Hi! Really sorry for this problem. Is it convenient for you to accept remote support? We can provide remote support from 10.00 am- 18.00 pm HKT on weekdays. If you have time for this, please contact me and we can make an appointment.

1 Like