D5 Converter for Blender (Beta)

D5 Converter for Blender is a plugin for those who want to use Blender scenes or models within D5 Render.

Version Support: Blender 2.8.2 and above


  • Export Selected: Export selected object or the entire scene.
  • PBR Material Support: Most of your PBR materials will be reconstructed entirely in D5 Render.
  • Speed and Quality: Textures are baked if and only if it’s necessary.
  • Customizable Texture Size: Up to 4k/8k texture generation.
  • Smart Object Optimization: Modifiers and instances will be handled properly.
  • Auto Update.

Not Support but on Roadmap:

  • Metal Texture
  • Particle Modifiers
  • Animation Support

Free Download and How to install

How to report a bug:

  1. Checked the “Debug Mode” in export options
  2. It will write a log into the destination folder
  3. Upload the log file with a short bug description

This plugin is still in beta, not the official release version. If you have any suggestions or bugs, please leave the message below on this topic without any hesitation.

Respect to Open Source.
Team D5.


Great News! Thank you.
I would like to report that translucency and alpha is not working.

Thanks for your feedback.

It’s a known issue, and the workaround way is using material template of custom alpha in D5 Render.

And it will be fixed in coming release of D5 Render. Stay tuned.

Thank you very much.
Looking forward to new version.

Fantastic! thank you guys! downloading and testing right away! :smiley:

Edit: works like a charm!

I love it!!
Thanks a lot!!

1 Like

Excellent. Tested with Blender 2.83 LTS. In my case it works very well with small scenes. but with large scenes it only generates an empty text file.

Hey Josue,

Thanks for your love. Could I have the large scenes which couldn’t be exported correctly for debugging?

You can send it with google drive, and my mail address is jingming.liu@d5techs.com

1 Like

Hi Josue,
i had same issue. There is some problem in your blender materials.
My work around was just deleted all materials and then export.
It works now.

@D5 Team.
But there is one big issue. When i export as D5 i can open in D5 but
all object shown just as 1 Object and as different object.
It means for example.
In Blender i have
1x Cube
1x Circle
1x Ball
after export and open to D5 i have only
1 Object.
Nothing helped.
Can you advice how it can be handled ?

Greets Andy

1 Like

Hey Andy,

Thanks for your feedback.

For now, the D5 Render treats the one .d5a file as the one object, we may develop the separation of one .d5a file by material or separated group in the future version.

The workaround way if you want to organize different models in D5 Render is exporting and importing these models one by one as different .d5a.

Hello and good day.
Thanks y lot for this information.
It means at the moment it is not same like in sketchup right ?
Normaly i dont care if it is one model but now i can not assign different material.

But anyway thanks for this work around.
CU soon ANdy

For this: Normaly i dont care if it is one model but now i can not assign different material.

Is that a bug? You can assign material in D5 Render to different parts that have separated by different materials in Blender.

Try to use a material picker tool on the top of the navigation bar, and the shortcut is ‘i’.

Did you enable the “export selected” option?

Same with me.

Hello and good day,
i found a work around.
First i deleted all materials from all objects.
Then i assign just a standard mat.
After that i exported. Then it works great.

Anyway thanks for the great work and the plugin.I hope in the future it will export all materials correct and in case of some mat error while exporting just exchange with an standard could fix it .

Greets Andy

Thank you for the good tool.
Large and small files are fully converted and can be used in the D5 render
Looking forward to further updates

1 Like

Anyone experiencing Blender crashing when attempting to export with D5 addon? Had this problem and reinstalled addon in Blender. Now it doesn’t crash but addon isn’t working. I get this message:

Not sure if I should post here though. Is there a bug report for the addon in Github or elsewhere?

I hade a similar problem and I solved unchecking the optix option in preferences- system.

Thanks for the tip. Sadly this doesn’t solve the problem in my case…