Cant open sketchup model

I’m newly to this render software… watched a bunch of videos and decided to download the program…

first try was ok, i was able to open the file and applied the textures to it… but i cannot adjust the materials somehow… so i closed it and tried to reopen it again… then ive been kept stuck at the loading screen, it does not seem it loads the model at all… any reason why? am i missing something?

my gup is RTX quardro 4000

Hi ausdot,

Thank you for your feedback.
Could you please elaborate your issue to me? Better with some screenshots or video of it, which can help us know more about it.

do you think it might have been because it is 2020? and it is not compatible just yet? should i save it down to like 2016? to give it a go? and the RTX studio drive is only for the gaming cards only… i am with RTX quardro 4000… will there be a drive that’s similar to the studio one?

Thank you!

Yep, I couldnt import a SU 2020 version either. Just save it as 2019 or below and it works perfeclty.

i tried 2019… didnt work… and then tried 2016… didnt work either. I am still stuck at the loading screen…i wonder if i need to reinstall the program. or my GPU is not really compatible?

Hi ausdot,

Please download and repair by the link below. Then restart D5 Render. The issue will be solved.
Thank you very much.

I am having the same issue. But 2019SU works fine. I have the current 1.9 d 5. Should I still install patch as listed above?

Hello allenm, no need to install the patch. To confirm, you were trying to open SU files directly, or using D5-SU converter? If the former, we do not support opening skp2021 files, and that is why SU2019 works fine. You could save the file in skp2019 format.
Besides, if you are using the plugin and SU2021 cannot work, please update the video driver first, or could you give me more details about the problem? The model disappear or has other abnormal behaviors?
And please check your video driver version, make sure it updated.


I just import the 2019 SU model.

the drafting program i use is Softplan. in that program i export 2019SU

Ok sir, we may not support that program Softplan yet, could you share with us the SU2019 file you exported using Softplan, we want to test and check whether we can support it, or the problem happens to a specific one.
My email is