2.4 Admin permission required

Odd problems with D5 2.4

  1. First time installed, no desktop icon showed up. It ran perfectly then exit the program, went to folder of D5 there was no exe launcher. D5 dint seem to get installed properly.

  2. During my first attempt to the run the program It didn’t show up the network mapped folders at all. We working in an organization where we have mapped folderes to our server. They refuse to show up at all. Clicking on the network icon in the explorer within D5 did nothing. I thought it was a corrupt install so i closed the program in this first install and tried to re run the new version again and realised there was no launcher EXE file present in the folders. :thinking: spellbound.

  3. Second install: Uninstalled previous version first and then reinstalled new version again. Desktop icon came thru. And seemed like all will be well. But after the opening of the app. Same issue “NO NETWORK DRIVES VISIBLE” :expressionless: Gave up. copied files to desktop from network drive manually. Opening file to new version. All working fine now. Untill i realised that each time i need to open new D5 verion of app it needs adminstrator access. “HEADACHE”
    Each time i need to have the IT guy to come and type the ADMIN access. “Irritating and frustrating”

  4. Another attempt at reinstallation: Uninstalled program. And now reinstalled with “Run as admin” mode. Ran the program, put in the admin details “its like the IT guy was attached to me hip like a Siamese twin, irritating and frustrating again” Program ran: Before the launch of program “ASKED ADMIN ACCESS AGAIN” gave access to install app as well as asking for access each time on launch. STILL DINT FIX THE NETWORK ISSUE.

  5. Decided to revert to D5 2.3 Installlation with admin access cleared. As well as run the app without asking any admin access needed. Continuing my work with 2.3 for now untill issues are resolved.


Hi Monks,

Did you install D5 Render 2.4 in a file path that needs admin permission, like C:\Program Files ?
If yes, then it will ask for admin permission every time you use it.
So it is not recommended to install D5 on that location.

I think it can be the same reason for D5 2.4 not recognizing the network drive. Please install D5 on another place then check the result.

Thanks for the info. Ill try installing D5 in my other drive next time.
What about the issue with no network mapped drive visibility?!


Hi mate, it can be the same reason, related to the admin permission. And can you let me know the NAS you use is what type or brand? You have mapped it into a local drive?

Hey Oliver,

Yes we have mapped drives linked to the server as drives on the system.
As per what you mentioned, The default installation happens to be in
C:\Users(username)\AppData\Roaming\D5 Render

The first time I had installed D2.4 it had been installed to that folder only.
And I had encountered the same issue of the mapped drives at the first install itself.
Also there was no desktop icon, so i couldn’t re-run the app. When i had gone searching for the app in the above folder I found no launcher exe as well.

I thought it might have been a corrupt install. So i reinstalled the application again in the same default location roaming. This time it had a correct installation because the desktop icon came thru.
But mapped drives were not showing up still.
I continued my work non the less and copied the files to the desktop and tested D5-2.4 and it worked perfectly fine. No issue as such.
Tried to install a third time thinking as they say “third times the charm” but changed the default folder to program files> and like u said admin access issues.

So i reverted to D5-2.3 as of now. Thats the story.
i will give it one more try and let me know if there are any log files (location?) that i could share with you, for you to get a better picture on what’s happening.

And i don’t know bout the kind of NAS they are using at office, and they wont let me know even if asked. Security concerns.


K. Good news.

Installed the D5-2.4 on my local D drive and mapped drives are working now. YAY :slight_smile:

Now all i need is help with the sketchup plugin not working?!

1 Like

Hi mate, how does the SU plugin not work? can you tell me more details?

Hey so i installed the plugin the latest one that says

From the zip file.
and I dont find it in the extention manager or anywhere in the toolbars??!!

Am i doing something wrong?

Hi mate, there is no D5 Converter in the tool bars panel?

Please turn off SU, and extract the installer file from the zip , then install again.
Did you once change the plugin folder of SketchUp?

Yes did that but still doesnt show up on the sketchup tool bar?!

Yes it is in default location

Cannot find anything with D5 in that list also. Even after installing.

Hi mate, in SU extension manager, is D5 Converter shown there?

If not, please try reinstalling D5 Converter (run the installer with administrator permission)

i will try and get back, but u can see in my screenshot here there is no sign of the D5 Converter at all in the list

K, i found out what the issue was.
When i ran the program,
Each time It asked me for admin access. No matter which user mode i was logged into.
And because i gave it admin access it installs the plugin in the admin directory “ONLY” and “NOT :no_entry_sign:” in the subsequent users directories as well.

So I made the IT guy sit next to me
SIGNED in to the ADMIN account. Installed the plugin. Copied the files screenshot below

in my user directory resulting in the working plugin.

NOTE: I again tried to install the plugin after login into my user account. And checked where the files were being installed and noticed that after typing the admin access password it installs the plugin into the admin directory.

Hence realized the issue and what’s been happening and why the plugin was not showing up.

I hope that helps you as a feedback to fix the issue for future plugin.

Thanks Oliver.

1 Like