Update Announcement 1.6.2

New features

  • Education Edition

  • Top view display mode (shortcut T)

  • Wireframe display mode

  • Multi selection function with the mouse (CTRL)

  • Search function in scene resource list

  • Character Motion Rate Matching Switch in Video

  • Light source keyframe switch in video

  • Video Timeline Zoom (ALT)

  • Alpha Channel Output

Adopts NVIDIA Deep Learning Super Sampling 2.0 (DLSS) technology (beta)

  • 1. Improve graphic quality in editing mode

  • 2. Boost video rendering speed (2K and 1080p) about 2X

  • 3. Reduce GPU memory usage

Requirements: RTX card + latest version of graphics driver

Switch to「DLSS on」


  • New filtered items for plants, people, etc.

  • Improved plant dispersal efficiency

  • Replaced the display of artificial light sources

  • Optimized the style of import resource list

  • Adjusted the model grouping rotation way

  • Optimized keyframe adsorption experience

  • Adjusted some UI details

  • Illumination no longer affects the axes

  • Optimized real-time transition experience

  • Increased video rendering speed

  • Improved stability


  • Errors in which model units are displayed inconsistently

  • Light source display error caused by Shift copy operation

  • Occasional crash in exporting panorama

  • Black block issue in material ID channel map

  • Renders with jaggies and black lines in two-point perspective mode

  • Custom size display error in exported images

reference- https://www.nvidia.com/en-us/geforce/news/nvidia-dlss-2-0-a-big-leap-in-ai-rendering/

1 Like

Hello, great to see new release. unfortunately, cannot update as the launcher is stuck at updating at 0%. Tried in different machines but ends up in same result. see attached pic.

This has been the way since the initial full release. As a workaround, we download the installer and reinstall the whole software. It seems ver. 1.6.2 is not yet added to download option.

Hopefully, d5 team will be able to find a way to fix the issue at earliest.

Thank you

Team Maverick

Please, update the download link for installer to current version.

Hi, may I know your location? Some files on the CDN node in your area are not updated correctly. And we are now working for this issue. For now, You can try to delete the previous download file and download-install again to solve this issue. If it doesn’t work please contact to me and tell me your email address, thanks a lot!

1 Like

Hi John, sorry unfortunately wasn’t able to update at all. my whole process was: Installed-update-stuck-force_close-crashed-reinstalled-repeat same process. I gave up and continued using 1.6.1 version as it was working.
my email address is: zinoarchi@yahoo.com
location: Dhaka, Bangladesh

p.s.: as i was searching for reasons for not updating i found in the log that the updater was trying to contact usa server and getting timed out. in the configuration file i noted: region is set to usa. Hope this may enable you to delve further into the matter.

Hi, thanks for your detailed answer! This message is very important for us! I have sent you a installation package, please check your email and have a try.

still no multibouncing for GI… no material emision singlesided or self illumination only, no background override, no interface scaling for 4k monitors…

multi bouncing is available in output. Please try to render an image.

Thank you